Registrati ora! Hai perso la tua password? Memorizza credenziali
Autore Messaggio
Gianni 29/11/2011 09:35

Modulo Ebay: errore duplicazione metodo di spedizione

Buongiorno,
sono sempre qui a darvi scocciature....
Purtroppo ho tanto lavoro da svolgere ed alcune funzioni mi sarebbero utili.
Il problema questo:
Dopo avermi creato un modello con html, spese di spedizione ecc..., pubblico le inserizioni dal nostro archivio ed ho notato che creando un inserzione singola va tutto bene, al momento che mi duplico un'inserzione creata precedentemente sempre in Ready avviene un errore.
Praticamente dopo aver clicca su ok e su PUBBLICA IMMEDIATAMENTE, Ebay restituisce un errore (vedi screenshot), infatti se riapro l'inserzione che non stata pubblicata, mi ritrovo che il tipo di spedizione stato duplicato (vedi screenshot) quindi mi ritrovo come metodo di spedizione POSTA PRIORITARIA, CORRIERE ESPRESSO, POSTA PRIORITARIA.
Se questa inserzione la duplico ancora mi ritrovo:
POSTA PRIORITARIA, CORRIERE ESPRESSO, POSTA PRIORITARIA, CORRIERE ESPRESSO.
e cos' via.
Sbaglio qualcosa?
Visto che il modulo permette di cliccare su duplica, a me comodo ricavare una nuova inserzione da quella precedente dato che devo cambiare solo la descrizione.
Attendo notizie
Giaqnni

Gianni 29/11/2011 09:45

Ooops
Chiedo scusa,
dopo aver duplicato un inserzione, il problema si manifesta se clicco su SALVA COME DA PUBBLICARE e non su PUBBLICA IMMEDIATAMENTE.
Nel primo caso mi da l'errore descritto sopra se procedo alla pubblicazione, nel secondo invece funziona.
Gianni

Fabio 30/11/2011 09:05 Campo libero:

Che versione di Ready Pro sta utilizzando?

Gianni 30/11/2011 09:24

Buongiorno,
la versione 13.9.17

Fabio 05/12/2011 11:06 Campo libero:

Non riusciamo a replicare l'errore in alcun modo purtroppo.
Potete inviarci una copia del vostro archivio dati che contenga un'inserzione con i servizi duplicati come nel vostro screenshot sopra?

COME INVIARE L'ARCHIVIO DATI AL SUPPORTO TECNICO:
http://www.readypro.it/readyForumPosts.asp?t=9712

WWW.CIAMPISTORE.IT 05/12/2011 11:48

in alcuni casi mi capitato anche a me, per risolvere ho dovuto eliminare l'oggetto duplicato e ri duplicarlo, l'errore dovrebbe verificarsi quando nella prima pubblicazione c' una qualche lentezza nel pubblicare l'inserzione

Fabio 12/12/2011 12:50 Campo libero:

Non siamo riusciti a replicare il problema ma abbiamo tentato di fare delle modifiche "alla cieca" con questo aggiornamento
http://www.readypro.it/download/pro/ReadyPro_Aggiornamento_13.9.35.exe

Fateci sapere se, dopo l'aggiornamento, il problema si dovesse presentare ancora

Gianni 12/12/2011 13:01

Grazie, lo provo subito.
Buon lavoro
Gianni

Fabio 12/12/2011 14:19 Campo libero:

Ok good!

Gianni 13/12/2011 10:03

Ciao,
il problema rimane, anzi ti do qualche info in pi perch ho cercato di capire la logica che ovviamente dal lato programmazione c', ma dal lato utente non si capisce molto.

Creao una nuova inzerzione (NON DUPLICATA MA NUOVA) con 2 metodi di spedizione:
1 Posta prioritaria
2 Corriere espresso


A questo punto salvo come in "preparazione".
Se questa inserzione la riapro e cancello il metodo di spedizione Corriere espresso e la salvo, quando la vado a riaprire mi accorgo che compare nuovamente come prima voce:
1 Corriere espresso
2 Posta prioritaria


A questo punto se cancello nuovamente Corriere espresso, salvo e riapro il risultato il segunete:
1 Posta prioritaria
2 Posta prioritaria


Ovviamente facendo altre prove sono uscite fuori altre situazioni che non sto ad elencare qui perch il discorso simile a quello gi esposto e questo avviene anche per le spedizioni internazionali.

Il problema si ha solo nella procedura "IN PREPARAZIONE" e "DA PUBBLICARE" e non quando si utilizza "PUBBLICA DIRETTAMENTE SU EBAY" e sempre quando un'inserzione viene riaperta e salvata o duplicata e salvata. INSOMMA L'ERRORE SI HA QUANDO UN INSERZIONE GIA' ESISTENTE SI SALVA SENZA PUBBLICARE.

Chiedo scusa se poco chiaro, ma un p difficile descrivere il tutto Grazie

Buon lavoro
Gianni

Gianni 13/12/2011 10:14

Shocked
Il problema si presenta anche se apro semplicemente un'inserzione in preparazione e la salvo senza apportare alcuna modifica e senza cliccare su alcun Tab, ma solo su salva.
crazy

Fabio 13/12/2011 11:08 Campo libero:

Sei stato chiarissimo. Abbiamo identificato il problema e rilasceremo un nuovo aggiornamento per risolvere a breve. Grazie per la descrizione dettagliata del problema Ok good!

Gianni 13/12/2011 11:17

Mi fa piacere Wink
Buona giornata
Gianni

Fabio 13/12/2011 14:40 Campo libero:

Questo aggiornamento dovrebbe risolvere il problema in maniera definitiva Ok good!
http://www.readypro.com/download/pro/ReadyPro_Aggiornamento_13.9.40.exe

Gianni 14/12/2011 09:59

Molto felice
Funziona bene adesso, grazie, ottimo lavoro
Buona giornata
Gianni

Fabio 14/12/2011 10:29 Campo libero:

Grazie per il feedback Ok good!
Buona giornata anche a te